Engage. Your Community

Dark screen areas flickering/brightness changing

I have an issue that I just can't seem to solve. On my laptop the screen appears to flicker or kind of pulse in brightness every few seconds, but only seems to be visible on the dark areas of the screen.

My laptop is an HP Omen which has both the inbuilt Intel and Nvidia 860M graphics card. I know some people have had issues with similar setups, but I can't seem to find anyone that has the same issue as me. I have tried all sorts of boot options to set various flags on the i915 driver but with no luck. But then I am not sure which card is actually being used.

Could someone please help me with trying to diagnose this. I have also tried Ubuntu and Linux Mint and they both have exactly the same issue.

Thanks

You could try changing the Intel graphics config, see here.

A hybrid graphics setup defaults to the Intel chip. To use both the graphics cards you need Bumblebee

I tried changing the Intel graphics config. I didn't have the file specified in the link /etc/X11/xorg.conf.d/10-intel.conf so I created it and restarted but unfortunately no change.

I did try and install Bumblebee as per the guide, all seemed to install fine but it didn't appear to run correctly, primusrun came up with errors. I then tried install the nvidia drivers as per this site http://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/ but it complained when installing the DKMS drivers and now my machine errors when booting :(

As stated on that Bumblebee guide you can't use the regular nvidia driver with Bumbleee. You need to use the nvidia driver from the Bumblebee site.

You could do a search for your Intel card and see if others have the same flickering problem. The Fedora kernel contains the latest Intel driver so there isn't an alternative driver available there. Is your system up to date?

I did try the driver mentioned in the guide first, then I got a bit sidetracked and decided to give the standard one a go.

ok thanks, I will continue to try and find more info.

I reinstalled everything again and tried disabling the i915 driver so it falls back on the VESA driver. This improves the situation greatly, however interestingly it hasn't gone away completely there is still a small amount of flicking depending on what is on screen.

This got me thinking that it might be screen driver/settings issue rather than the Intel driver

I think I am having the same problem. https://www.youtube.com/watch?v=o1GyKGxmuDI ... this is my screen... have you found any solution? I noticed that if I reboot from Korora to Windows without shutting down the computer, the screen keep flickering also on Windows

Giraffe81/otapliger,

Have you isolated your issue to something software realated? Does everything work fine in another OS? I just ask, so we can make sure it isn't a faulty back light going bad. I've had one monitor in the past that flickers and failed when bright objects (such as a lot of white background) would appear on the screen. Unfortunately, it was a known issue with the brand and model of monitor.

With that out of the way, I had to implement acpi_backlight=video in my grub boot config to fix backlight issues i had starting with version 23 or 24. I can't remember when it started. I still have the fix implemented though. I am also on hybrid graphics setup (nvidia/intel). And i've been abusing the nvidia lately as an alternative heat source this winter. haha.

Link i originally used and where i got the fix that helped me. Maybe that same option can help you. If not, there are some other options to try in the link. https://roshi.fedorapeople.org/fixing-backlight-issues.html

Hope this helps.

On windows, everything runs ok. But as I said, if I boot on Korora and then do a soft reboot, the screen flickers on windows too until I do a shutdown repower again. The problem is caused by Korora but it persists in other OS too if I don't shutdown and repower again. I am downloading the Ubuntu live iso to try it there too, to test if my problem is with Korora or Linux in general. I will try your suggestion too, thanks!

otapliger wrote:
I think I am having the same problem. https://www.youtube.com/watch?v=7qW4-mWpk1k ... this is my screen... have you found any solution? I noticed that if I reboot from Korora to Windows without shutting down the computer, the screen keep flickering also on Windows

Is the system up to date? Which desktop are you using? It looks like Gnome. If so have you tried starting it in Xorg mode rather than Wayland? What graphics do you have?

otapliger wrote:
On windows, everything runs ok. But as I said, if I boot on Korora and then do a soft reboot, the screen flickers on windows too until I do a shutdown repower again. The problem is caused by Korora but it persists in other OS too if I don't shutdown and repower again. I am downloading the Ubuntu live iso to try it there too, to test if my problem is with Korora or Linux in general. I will try your suggestion too, thanks!

If it works in Ubuntu it may be a regression in the graphics driver as Fedora usually has newer drivers than most other distros.

Ok, I had the same problem with Ubuntu. But I also found out a solution. In our case (Korora), we basically have to edit the grub config file, changing the line

GRUB_CMDLINE_LINUX="rd.lvm.lv=korora/root rd.lvm.lv=korora/swap rhgb quiet"

with

GRUB_CMDLINE_LINUX="rd.lvm.lv=korora/root rd.lvm.lv=korora/swap rhgb quiet i915.enable_psr=0"

Apparently the issue is with Panel Self Refresh (psr).

Font source: http://askubuntu.com/questions/840562/ubuntu-weird-brightness-flickering

Thanks for the update, hopefully it will help others.

Please Log In to participate with the community.