Engage. Your Community

Disabling Touchscreen on Lenovo Yoga 700

I recently installed Korora on a 2-in-1 hybrid tablet, the Lenovo Yoga 700. Everything is working fine except for the screen. I upgraded right after I installed Korora because of a recursive fault that prevented the system from booting up. After the upgrade, the touchscreen rotates about 4 or 5 times before it goes back to normal except it does this with the slightest movement, including typing. How do I disable the screen rotation in the device? I am pretty much a newbie when it comes to using terminal and I have tried a lot of methods that I do not understand. Naturally, none of them have worked. Thank you.

Screen rotation is an ongoing issue and one that doesn't seem to have an easy answer. Unfortunately no one on the team has the hardware to test this which means we rely on reports from others. There are outstanding previous issues such as this one.

Which desktop are you using? If it is Gnome you can try starting in Xorg rather than Wayland, there is an option on the login screen. Also see here for the option to turn autorotate off.

If you are using Gnome you can also lock screen rotation via the GUI at the top right of the top bar.

For Cinnamon, there's a keyboard shortcut for Orientation Lock. In the applications menu, run Preferences -> Keyboard. Navigate Categories -> System -> Hardware -> "Orientation Lock." I have unmapped mine because I needed the key for something else, but it will show you the default keybinding.

Please Log In to participate with the community.