Engage. Your Community

Double Icon for Libreoffice on Dash to Doc

I just successfully upgraded from Korora 24 to 25.

Now when I launch libreoffice I get a second icon with no logo

I have tried to use xprop, but it doesn't react when I click on Libreoffice.

In the .desktop file the correct setting used to be:

StartupWMClass=libreoffice-writer

But now this does not seem to work.

Any ideas on how to fix this will be much appreciated?

Is it only Libreoffice that does this? Other applications work as expected?

One thing you can do is change the settings to not show running applications. Go to Tweak Tool - Extensions - Dash to Dock - Settings - Behaviour and un-select the second option.

All other applications work as expected only Libreoffice has this problem.

Libreoffice Version: 5.2.3.3 Build ID: 5.2.3.3-10.fc25

If I unset show running applications - this cures the double icon problem.

But then I lose funtionality that I need like minimizing on click etc..

I have also noticed this behaviour but with gnome software. However it happens only in a wayland session. Can you check if it is better when you start an Xorg session ?

@axelmeunier you nailed it!

It only happens with Wayland on Xorg everything is back to normal.

Thanks.

Happy to report that this now works on Wayland also!

Thanks to all for making this such a fun distro.

eistconn wrote:
Happy to report that this now works on Wayland also!

Thanks to all for making this such a fun distro.

Thanks for the update. Wayland will keep getting better and problems like this will disappear.

Please Log In to participate with the community.