Engage. Your Community

GDM Log-in not working

Hi all,

Sorry to be a nuisance, I was trying out the LXDE desktop and I did a

$ sudo dnf group remove lxde-desktop

I think it removed more than I wanted because afterwards I failed to get the login for Gnome which is my preferred desktop. I tried booting into older kernel version and still have the same problem.

So I am just getting a terminal prompt. However I can start Gnome with:

$ startx

Once I do that everything works fine.

On booting I see this error:

May  8 17:37:39 xxxx kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-N10   00001050 PTEC 00000002)
May  8 17:37:39 xxxx kernel: Error parsing PCC subspaces from PCCT
May  8 17:38:27 xxxx kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-N10   00001050 PTEC 00000002)
May  8 17:39:46 xxxx kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-N10   00001050 PTEC 00000002)
May  8 17:39:46 xxxx kernel: Error parsing PCC subspaces from PCCT
May  8 18:17:09 xxxx kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-N10   00001050 PTEC 00000002)
May  8 18:17:09 xxxx kernel: Error parsing PCC subspaces from PCCT

As usual any help much appreciated.

I think I have fixed it by doing the following:

 sudo system-switch-displaymanager gdm
Created symlink /etc/systemd/system/display-manager.service → /usr/lib/systemd/system/gdm.service.
Your default graphical display manager has successfully been switched.

I guess the gdm.service was not starting

It usually isn't a good idea to remove a desktop as it can remove system files. If you have fixed it that is good. Often in these cases the only option is to reinstall.

In future if you want to try another desktop it is better to do a dnf history undo rather than remove. Check man dnf for the full command. Another alternative is to use a VM, kvm is built into the kernel.

Please Log In to participate with the community.