Engage. Your Community

Intel Graphics screen tearing VLC

This problem is something i had with almost every distro . The problem is that when i watch videos(Mainly matroska video format files),The screen gets teared at the top. Resulting into a small but eventually annoying glitch.

Im running Korora 20 Cinnamon,

This mostly happens when the frame rate gets higher becouse of the Animation in the video(A.K.A in Anime).

I could fix this on Arch by applying this configuration file in the /etc/X11/xorg.conf.d/ directory.

I tried this on Korora but it didn't show any success.

I hope that this information is sufficient. And also hope that Korora will become an distro that has Anti Tearing features right out of the box.

I installed XFCE and it also Happened there.

I think it will happen on any desktop as it is a driver issue. Did you try setting to UXA as described earlier in that link you gave?

ozjd wrote:
I think it will happen on any desktop as it is a driver issue. Did you try setting to UXA as described earlier in that link you gave?

I am not sure if that will work i have a ASUS X750-J Laptop.

[Edit] Affirmative it did not work.

I have the same problem with the following specs: Intel Core i7-3630QM (intel HD graphics 4000, 2GB ddr3 vram) Nvidia Geforce GT 740M (2GB ddr3 vram) 8gb ddr3 dual channel ram

I don't have drivers installed for my nvidia GPU yet but i will try that soon. I dont know how to fix this.

Hikari

If you are going to install the nvidia drivers you will need to disable the Intel graphics first.

Jim

It's probably not taking effect because by default the Intel driver still uses UXA acceleration.

You'll first need to add a config that tells Intel use use the newer SNA, see here: http://blog.christophersmart.com/2013/08/21/fixing-gnome-3-freezes-on-sandybridge-and-later-intel-graphics/

Then try also adding your fix from Arch.

OK I thought I'd expand this a little as it may appear slightly different in Korora 20 due to journald, etc.

So basically just put the file below to /etc/X11/xorg.conf.d/10-intel.conf

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "AccelMethod" "sna"
  Option "TearFree" "true"
EndSection

Reboot.

Verify that you're now running in SNA mode:

journalctl -e /usr/bin/Xorg |egrep -i "uxa|sna" |tail -1

Hope that helps, let us know if it works.

@csmart that command returns nothing if you are in uxa mode. Haven't tested in sna.

glxinfo | grep "OpenGL vendor" does show the correct info.

Please Log In to participate with the community.