Engage. Your Community

Keyboard repetition

Hi. I recently installed Korora 25 in my Dell XPS 12. Sometimes, the keyboard goes crazy and starts repeating the action a large number of times. The biggest issue with that is when I delete something (specially emails), it keeps on deleting! Any way to fox this?

Which desktop are you using?

Is there any pattern to the repetition? Are the same keys or applications involved?

Hi, and thanks for the reply. I am using Gnome. No specific pattern nor application involved. Thanks again.

Okay, probably not the issue but one thing but one thing worth checking with Gnome in 25 is Wayland. As it is now standard there are some previously unknown issues surfacing. Try starting in Xorg mode, there is an option at login.

Also found this for XPS13 and wonder if it applies.

Also found this.

Thanks. Will try those and update...

Tried both approaches. The BIOS update didn't do much, but using Xorg reduced the issue significantly. It still happens, but much less. Any other ideas?

Thanks for the update. I don't have a Gnome system at the moment but in settings is there a choice of keyboard profiles. Maybe changing that may improve things.

I tried KDE and Mate and both have the same issue. I am nor trying MATE but with the option to allow keyboard repetition off.

Is your system up to date?

On Mate under System - Hardware - Keyboard - Layout there is an option to change the keyboard model. There are a few options for Dell. Have you trying changing those?

Yes, the system is up to date. I tried different Dell keyboards and same issue. When I did unselect keyboard repetition, the issue goes away. However, that makes moving around tedious (using arrows one step at a time instead of keeping it pressed).

It sounds like some sort of driver issue but where to go from there I've no idea, sorry. I did some searching and couldn't find any other recent reports.

Thanks for your help. I am about to give up on Korora on this machine.

One thing you could try is to install Fedora. It should have the same issue and if it does you can report a bug at https://bugzilla.redhat.com/. I suspect it is a driver issue and as such is likely to happen in any Linux system.

Thanks, that's what I did and the issue is there still. Thanks a lot for your help, I really appreciate it!

Please Log In to participate with the community.