Engage. Your Community

laptop gaming touchpad and keyboard

I'm trying to game on my laptop (using steam) and am running into an issue. When i try to move (using my keyboard keys "wasd" and my touchpad) i believe a disable touchpad while typing feature is kicking in and i can not use the touchpad. As soon as i let go of key, it works. I'm using gnome, and their used to be a setting to disable this feature in gnome settings once upon a time. But, this feature appears to have been taking out. This leads me into another issue. I figure no big deal. I'll retrain my hands to use the keyboard differently. My laptop keyboard has both arrow keys and a number pad with numlock key and arrows. My "designated" arrow keys work while using the touchpad at the same time. But these keys are too small and my hand becomes cramped. So i try to use the arrow keys on the larger number pad but for some reason in games with the numlock off these arrow keys do not work. But the arrow keys will work in a office document. But they often don't work in citrix apps, or even in some other non-steam games (zdoom, pbroom) or others. I don't even know where to toubleshoot this. I always thought the numlock turned the arrow keys into the same arrow keys found elswhere on the keyboard.

Anyways, i find it hard to believe this has never been an issue for anyone else. Thanks for any help. Currently running korora 25 gnome that has been upgrade from 23 on a MSI GT70 laptop.

After all this, i have to say WOW. There appears to be multiple ways to accomplish this task. And from the lengthy forums, articles, and blogs i've read this appears to be a "design" choice to not have this option in gnome settings. I found one reddit post quite interesting where someone was working on a patch. The solution i'm currently using is the xinput command along with a script that i found on github. It's simple and easy to understand with instructions. I'll provide a link to the script as well as to some some other articles i read on xinput and libinput. Never just randomly run stuff you don't understand so i made sure i knew what was happening.

I tested the xinput commands from terminal first to make sure it would suit my needs. I would use the command xinput --list-props "name of device" to view the actual changes after applied. I made directory on my home drive called "bin" and put the script there so i can call it easily anytime (drop down terminal) or i might add it to my steam startup. Link to script: https://gist.github.com/jkoelker/7d1bfad5d6adc78e03ed7bf6a42fbf1e

More information on xinput and configuring touchpad http://www.mepis.org/docs/en/index.php?title=Configuring_the_touchpad_with_xinput Reddit discussion on why setting was removed and about someone creating a patch https://www.reddit.com/r/linux/comments/4dqhtr/whot_why_libinput_doesnt_have_a_lot_of_config/ Blog Post about libinput and disable-while-typing http://who-t.blogspot.com/2016/08/libinput-and-disable-while-typing.html?m=1

I hope this helps someone who has the same issue. For me, i just now hit ~ to bring up drop down terminal and run gaming e or gaming d for when i want to toggle this option. I of course also replaced my touchpad model in the script with SynPS/2 Synaptics TouchPad

accepted

I haven't got a Gnome system handy to check but I think there are keyboard and touchpad settings available in Tweak settings.

Not sure if it is the issue but if the keys are set in the game or Steam they may not be recognising the number pad. Number pad keys report differently to the regular arrows keys. You may need to redifine the key bindings.

You can see the key codes with xev, start it in a terminal and press the corresponding keys from the arrow pad and the number pad. IIRC they are different.

This may affect you too but he hasn't reported which desktop it is

Thanks for the reply. You confirmed my suspicion that number pad and arrow keys are defined differently. I also checked out the mouse settings in tweak tool but nothing super helpful their. I read some where the option (disable touchpad when typing) was removed when the switch to libinput from synaptic became the norm. I'll check out the universal settings options and see if that makes a difference (which i think those touchpad settings should be in the mouse/touchpad ares). I think the short answer will be to change keybindings and see if i can work something out. I wonder what other people do, or am i just in the minority?

Thanks ozjd for the quick reply.

Update: The Universal Access>Pointing&Clicking>Mouse Keys toggle turned the arrow keys on my numpad into keys that move the mouse very slowly. This setting appeared to ignore weather numlock was on or off. I guess depending on your use case this could solve an issue, but in my case it didn't help. But now i know this setting and will keep in in the back of my mind for other use cases.

SirWeazel wrote:
Update: The Universal Access>Pointing&Clicking>Mouse Keys toggle turned the arrow keys on my numpad into keys that move the mouse very slowly. This setting appeared to ignore weather numlock was on or off. I guess depending on your use case this could solve an issue, but in my case it didn't help. But now i know this setting and will keep in in the back of my mind for other use cases.

Good to know, thanks. I thought that was for Gnome but I wasn't sure.

Update: This is more for anyone following this and my personal notes. I haven't implemented this yet since my quick solution has been to just use a gamepad on my laptop. But at some point i plan on tackling this and when i do find the "tweak" that works my next fix will be to implement it into a script that running will toggle the setting on and off. Maybe by that time it will be included back into gnome settings. Hopefully this will help someone else and if it does then please add to this thread. I've added two links i found to be informative along with the instructions someone left in a comment further down in the provided links. https://ask.fedoraproject.org/en/question/66444/disable-touchpad-while-typing-on-gnome-fedora-22/

https://wayland.freedesktop.org/libinput/doc/latest/group__config.html#ga5e30865097b8fa273c3e3cbcdff51b0f

Excerpt taken from one of the links above: It's actually configurable for the libinput driver for Xorg even though you can't find any GUI setting for it in Fedora 23 under mouse & touch pad

open the file /usr/share/X11/xorg.conf.d/90-libinput.conf

Under the section for the device with the identifier "libinput touchpad catchall" add the optioons

Option "PalmDetection" "True" Option "DisableWhileTyping" "true"

Will require a logout to take effect. Option "PalmDetection" "false" Option "DisableWhileTyping" "false" to enable touchpad whilst typing on Fedora 24 - for gaming when I forget my mouse

After all this, i have to say WOW. There appears to be multiple ways to accomplish this task. And from the lengthy forums, articles, and blogs i've read this appears to be a "design" choice to not have this option in gnome settings. I found one reddit post quite interesting where someone was working on a patch. The solution i'm currently using is the xinput command along with a script that i found on github. It's simple and easy to understand with instructions. I'll provide a link to the script as well as to some some other articles i read on xinput and libinput. Never just randomly run stuff you don't understand so i made sure i knew what was happening.

I tested the xinput commands from terminal first to make sure it would suit my needs. I would use the command xinput --list-props "name of device" to view the actual changes after applied. I made directory on my home drive called "bin" and put the script there so i can call it easily anytime (drop down terminal) or i might add it to my steam startup. Link to script: https://gist.github.com/jkoelker/7d1bfad5d6adc78e03ed7bf6a42fbf1e

More information on xinput and configuring touchpad http://www.mepis.org/docs/en/index.php?title=Configuring_the_touchpad_with_xinput Reddit discussion on why setting was removed and about someone creating a patch https://www.reddit.com/r/linux/comments/4dqhtr/whot_why_libinput_doesnt_have_a_lot_of_config/ Blog Post about libinput and disable-while-typing http://who-t.blogspot.com/2016/08/libinput-and-disable-while-typing.html?m=1

I hope this helps someone who has the same issue. For me, i just now hit ~ to bring up drop down terminal and run gaming e or gaming d for when i want to toggle this option. I of course also replaced my touchpad model in the script with SynPS/2 Synaptics TouchPad

accepted

Please Log In to participate with the community.